Jump to content

Recommended Posts

Hello I was wondering if anyone could help me with my minn kota ipolt lock spot. Every time I hit lock spot on the trolling motor the motor goes back and fourth and then spins till the cord is completely wrapped around all the way till I shut it off. If it doesn't do this it clicks into 9th gear and takes off till I shut it off. Anyone happen to know how to fix this ?

Share this post


Link to post
Share on other sites

I have found spot lock works best if I ease up to the location and don’t use it until I’ve slowed down, it makes the whole spot lock thing less violent.

Have  your batteries tested and replace the battery in your remote:   I’ve occasionally had the head wrap thing but the other items you mention would cause me to be concerned.  I have had intermittent performance issues with my motor if the battery is near dead in the remote.  If that fails, take it to aikmans sports in Mississauga, they are a Minkota repair facility.

Edited by porkpie

Share this post


Link to post
Share on other sites
1 hour ago, porkpie said:

I have found spot lock works best if I ease up to the location and don’t use it until I’ve slowed down, it makes the whole spot lock thing less violent.

I have a spot lock anchor. It has 200ft of rope. Never let me down.

Share this post


Link to post
Share on other sites

spotlock on mine is a  tackdriver.  sorry not much help with yours.  but yea if you hit spotlock while moving it will take ya back to where you hit it.    do you have the seperate white puck compas dohicky on yours? 

Share this post


Link to post
Share on other sites

Make sure the software is up to date on the unit.   Does yours have a heading sensor? (White puck)

I've also read about the wiring inside the control head being wrong from the factory.   You wanna make sure the power cable are all bunched up on one side of the head, some guys have opened theirs up and the power cables make a big circle around the control head which messes up the heading sensor.

Edited by BillM

Share this post


Link to post
Share on other sites

It does gun it sometimes to get you to the lock spot and in the process the cord sometimes does one wrap around the shaft as motor shuffles to get you on the spot. I noticed it happens for obvious reasons like when hit going fast or windy. We just live with the wrap and unwrap when you take off. I have a PD but my buddy who I fish with got a new rig with a terrova and we fish out of that now... spot lock is a game changer... amazing. I heard the new terrova's have improved spot lock.

 

Share this post


Link to post
Share on other sites

What year spotlock? My 2017 terrova is dead on. My old power drive was a hit or miss.

 

edit: the heading sensor that the new terrova/ultrex comes with has nothing to do with spot lock

Edited by boombap

Share this post


Link to post
Share on other sites

Tried to switch out the batteries and didn't work. I must have to get it fixed. I don't not have a white puck . I tried it again today and did the same thing. Thanks for the tips 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...