Jump to content
glenner

Motor guide problem

Recommended Posts

I have a Motorguide Pro series 46 bow mount TM that has worked trouble free until today.

I had been using it for about an hour when it acted up - it stopped running for a few seconds, then started again with a bit of a jerk, then ran for a few minutes, stopped, started a few times then just stopped for good.

When I got back I checked what I could, battery is fine, all connections I can see seem fine, it just won’t run.

Any suggestion on a next step?

Does anyone know a repair shop I could take it to for a diagnosis? I live in Guelph but my cottage is just north of Orillia.

Share this post


Link to post
Share on other sites

Pulled the head off and everything looks fine, likewise the wiring in the pedal

 

Share this post


Link to post
Share on other sites

Was there any grinding or whining sound prevalent? I had a similar issue on my older MG & root cause was the gear box opening up from loose bolt nuts. Bit of a pita to disassemble & repair but an easy DIY. 

Share this post


Link to post
Share on other sites

I have a similar TM, found wiring burnt at the switch contacts. (Loose terminals) tightened up, cleaned terminals, been mint ever since. One suggestion, if using a breaker, make sure it hasn't overheated and "opened" inside, leaving no voltage to pass through it. Check for voltage going in and out from your source to the under pedal switches. That should easily lead you to where your issue is. Good luck.

 

Edited by Smokercrafty

Share this post


Link to post
Share on other sites

Pikeslayer - No, there was no noise, it just seemed to stop, and then start aagain a couple of times then quit

Smokercrafty - Thanks, I’ll check the breaker and check the voltage when I’m back up on the weekend, don’t have a tester at the cottage

Share this post


Link to post
Share on other sites

Check all the terminals on the relay switch to see if anything may have fried inside.  For service, check with Rocky's in Orillia.  I know he does Minn Kota parts and service, but not sure about Motor Guide.

Share this post


Link to post
Share on other sites

Does that motor have high by pass.

If it works on hi bypass  It's likely computer or

the motor if it doesn't.

 Cost the same amount for either repair.

I don't know a MG repair guy check with Angler Outfitter.

Share this post


Link to post
Share on other sites

hey glenner, if things dont work out for you, ive got a motorguide digital tour up for sale in the classifieds at a stupid low price. It may be too much power if you have a small boat, but let me know if you are interested.

Share this post


Link to post
Share on other sites

Thanks Akrisonet, it is a great price but too much motor for me and I want to stay with a 12V as I don’t really have room for another battery.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×