Jump to content

Sign in to follow this  
rhare

Lund Onboard charger troubleshooting

Recommended Posts

Im having some minor electric issues and was wondering if anyone else might have had the same type problem.

 

when I hook up my onboard charger, it tells me the batteries are full when infact they are only 1/3 full.

 

I have 2 batteries hooked up on a switch with an automatic charging isolator, last year I had no issues with the system.

 

Ive checked the batteries, Ive switched the charging isolator, checked the connections. everything seems fine.

 

even when I disconnect one battery, the charger still thinks the other battery is full.

 

should I look at the onboard charger itself? Do they pooch easy?

 

 

thanks any help appreciated

Share this post


Link to post
Share on other sites

thanks thats kind of what I thought, I think I might replace it with a minn kota multi bank charger.

Share this post


Link to post
Share on other sites

Get a multi meter and test battery should be 12+ and if fully charged 13.25. Plug your battery charger in and test battery should be more than 13.25, if it is your charger is working.

 

You can test your boat charging system the same way.

 

Garnet

Edited by Garnet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...